安装TronBox

TronBox 环境依赖

  • NodeJS >=8
  • Windows, Linux or Mac OS X
  • Docker Engine >=v17

安装 Node.js

Linux and macOS

Node Package Manager(NPM)建议用 Node Version Manager(nvm) 安装 Node.js,以避免全局安装时出现权限错误。

1.使用 curl 或者 wget 来安装 nvm:

curl -o- https://raw.githubusercontent.com/nvm-sh/nvm/v0.39.1/install.sh | bash

wget -qO- https://raw.githubusercontent.com/nvm-sh/nvm/v0.39.1/install.sh | bash

2.确认 nvm 安装正确。你可能需要重新加载终端才能使命令生效。

nvm --version

3.使用 nvm 来安装一个兼容的 Node.js 的版本。例如,要安装 Node.js v12,运行。

nvm install 12

4.通过运行 node --version,确认 Node.js 已经正确安装。

Windows

TronBox 建议使用 Node.js 网站上的安装程序。

确保在安装过程中选择自动安装必要的工具, 以安装所需的 Visual Studio 构建工具、Python 和 Chocolately 包管理器。

612612

安装 TronBox

只要通过以下命令就可以安装 TronBox

npm install -g tronbox

在安装过程中,你可能会收到一串警告。为确认 TronBox 安装正确,请在终端上输入 tronbox version 来检查 Tronbox 是否正确安装。

tronbox version

Windows 用户需了解

如果您在 Windows 上运行 TronBox,您可能会遇到一些可能阻止 TronBox 正常执行的命名冲突。可阅读 tronbox-配置 中的“解决Windows命名冲突” 章节寻求解决方案。